[PATCH] Change void* into explict vm_struct*

From: Minchan Kim
Date: Wed Dec 21 2011 - 22:33:31 EST


Now, vmap_area->private is void* but we don't use the field
for various purpose but use only for vm_struct.
So change it with vm_struct* with naming and it's more good
for readability and type checking.

Signed-off-by: Minchan Kim <minchan@xxxxxxxxxx>
---
mm/vmalloc.c | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/mm/vmalloc.c b/mm/vmalloc.c
index e1fa5a6..6e3945d 100644
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
@@ -256,7 +256,7 @@ struct vmap_area {
struct rb_node rb_node; /* address sorted rbtree */
struct list_head list; /* address sorted list */
struct list_head purge_list; /* "lazy purge" list */
- void *private;
+ struct vm_struct *vm;
struct rcu_head rcu_head;
};

@@ -1265,7 +1265,7 @@ static void setup_vmalloc_vm(struct vm_struct *vm, struct vmap_area *va,
vm->addr = (void *)va->va_start;
vm->size = va->va_end - va->va_start;
vm->caller = caller;
- va->private = vm;
+ va->vm = vm;
va->flags |= VM_VM_AREA;
}

@@ -1388,7 +1388,7 @@ static struct vm_struct *find_vm_area(const void *addr)

va = find_vmap_area((unsigned long)addr);
if (va && va->flags & VM_VM_AREA)
- return va->private;
+ return va->vm;

return NULL;
}
@@ -1407,7 +1407,7 @@ struct vm_struct *remove_vm_area(const void *addr)

va = find_vmap_area((unsigned long)addr);
if (va && va->flags & VM_VM_AREA) {
- struct vm_struct *vm = va->private;
+ struct vm_struct *vm = va->vm;

if (!(vm->flags & VM_UNLIST)) {
struct vm_struct *tmp, **p;
--
1.7.6.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/