Re: [PATCH v3 resend2] s3c/s3c24xx: arm: leds: Make s3c24xx LEDSdriver use gpiolib

From: Joe Perches
Date: Tue Dec 13 2011 - 16:28:53 EST


On Tue, 2011-12-13 at 23:21 +0200, Denis Kuzmenko wrote:
> Hi Joe,
> Thank you for review.
>
> On 12/13/2011 11:06 PM, Joe Perches wrote:
> > On Tue, 2011-12-13 at 22:22 +0200, Denis Kuzmenko wrote:
> >> Make s3c24xx LEDS driver use gpiolib. Fix error disabling pull during probe.
> > []
> >> diff --git a/drivers/leds/leds-s3c24xx.c b/drivers/leds/leds-s3c24xx.c
> > []
> >> @@ -45,23 +45,35 @@ static void s3c24xx_led_set(struct led_classdev *led_cdev,
> >> + /*
> >> + * ensure value is 0 or 1 to use it with bitwise XOR (^)
> >> + * (only 100% brightness is supported)
> >> + */
> >> + value = value ? 1 : 0;
> >
> > Maybe value = !!value;
>
> IMHO my variant is better readable.
>
> >> + /* no point in having a pull-up as we are always driving */
> >> + s3c_gpio_setpull(pdata->gpio, S3C_GPIO_PULL_NONE);
> >> + ret = gpio_direction_output(pdata->gpio,
> >> + !!(pdata->flags & S3C24XX_LEDF_ACTLOW));
> >
> > akin to this use.
>
> There is no so much space for implementation used before so I've used
> shorter notation, again, for better readability.

Your choice, but I think consistency is better.

The LEDF_ACTLOW use is dependent on it being #defined
to 1 when using ^. I think that's unintelligible.

cheers, Joe

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/