Re: [PATCH 1/6] user namespace: make signal.c respect usernamespaces (v4)

From: Matt Helsley
Date: Wed Nov 09 2011 - 20:41:24 EST


On Wed, Nov 09, 2011 at 08:18:53AM -0600, Serge E. Hallyn wrote:
> Quoting Andrew Morton (akpm@xxxxxxxxxxxxxxxxxxxx):
> > On Fri, 4 Nov 2011 22:24:37 +0000
> > Serge Hallyn <serge@xxxxxxxxxx> wrote:
> >
> > > +static inline void fixup_uid(struct siginfo *info, struct task_struct *t)

nit: Seems like the function name itself needs a fixup. I can imagine a
user-ns-unaware kernel developer thinking this when they see code calling
this function:

<naive>
Gosh, why is the uid broken? I have no idea what this does or when it
would be needed. Why hasn't it been splatted all over the kernel? Who broke
it?
</naive>

You can't even tell from the name that it's for user namespaces.

Cheers,
-Matt

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/