Re: [PATCH] TRACING: Fix a copmile warning

From: Jesper Juhl
Date: Tue Jul 26 2011 - 09:19:01 EST


On Tue, 26 Jul 2011, Paulo Marques wrote:

> Steven Rostedt wrote:
> > On Mon, 2011-07-18 at 17:40 +0800, stufever@xxxxxxxxx wrote:
> >> From: Wang Shaoyan <wangshaoyan.pt@xxxxxxxxxx>
> >>
> >> It's harmless but annyoing.
> >> kernel/trace/trace_printk.c: In function 'module_trace_bprintk_format_notify':
> >> kernel/trace/trace_printk.c:52: warning: 'fmt' may be used uninitialized in this function
> >
> > I prefer not to add this patch. Fix gcc. Actually some gcc's do not warn
> > on this, others do. Here's the code that confuses gcc:
> >
> > tb_fmt = kmalloc(sizeof(*tb_fmt), GFP_KERNEL);
> > if (tb_fmt)
> > fmt = kmalloc(strlen(*iter) + 1, GFP_KERNEL);
> > if (tb_fmt && fmt) {
> > list_add_tail(&tb_fmt->list, &trace_bprintk_fmt_list);
> > strcpy(fmt, *iter);
> > tb_fmt->fmt = fmt;
> > *iter = tb_fmt->fmt;
> >
> >
> > fmt will never be looked at if tb_fmt is NULL, and fmt is initialized if
> > tb_fmt is not NULL.
>
> Yes, changing code just to please gcc is not nice. In this case,
> changing the code to the more straightforward / naive implementation
> might make it more readable (IMHO) and maybe even improve code
> generation. I.e., something like this:
>
> tb_fmt = kmalloc(sizeof(*tb_fmt), GFP_KERNEL);
> if (tb_fmt) {
> fmt = kmalloc(strlen(*iter) + 1, GFP_KERNEL);
> if (fmt) {
> list_add_tail(&tb_fmt->list, &trace_bprintk_fmt_list);
> strcpy(fmt, *iter);
> tb_fmt->fmt = fmt;
> *iter = tb_fmt->fmt;
> } else {
> kfree(tb_fmt);
> *iter = NULL;
> }
> } else {
> *iter = NULL;
> }
>
> The downside is that the "*iter = NULL" gets repeated twice...
>

You could avoid that like this:

*iter = NULL;
tb_fmt = kmalloc(sizeof(*tb_fmt), GFP_KERNEL);
if (tb_fmt) {
fmt = kmalloc(strlen(*iter) + 1, GFP_KERNEL);
if (fmt) {
list_add_tail(&tb_fmt->list, &trace_bprintk_fmt_list);
strcpy(fmt, *iter);
tb_fmt->fmt = fmt;
*iter = tb_fmt->fmt;
} else {
kfree(tb_fmt);
}
}


--
Jesper Juhl <jj@xxxxxxxxxxxxx> http://www.chaosbits.net/
Don't top-post http://www.catb.org/jargon/html/T/top-post.html
Plain text mails only, please.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/