Re: [PATCH 4/6] x86,64: Separate arg1 from rbp handling in SAVE_REGS_IRQ

From: Jan Beulich
Date: Mon Jul 04 2011 - 03:34:20 EST


>>> On 02.07.11 at 18:29, Frederic Weisbecker <fweisbec@xxxxxxxxx> wrote:
> Just for clarity in the code. Have a first block that handles
> the frame pointer and a separate one that handles pt_regs
> pointer and its use.

While possible indeed making the code easier to read, it increases the
chance of a latency related stall (due to the write to %rdi immediately
preceding its use as a memory operand's address).

Jan

> Signed-off-by: Frederic Weisbecker <fweisbec@xxxxxxxxx>
> Cc: Ingo Molnar <mingo@xxxxxxx>
> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
> Cc: H. Peter Anvin <hpa@xxxxxxxxx>
> Cc: Peter Zijlstra <a.p.zijlstra@xxxxxxxxx>
> Cc: Arnaldo Carvalho de Melo <acme@xxxxxxxxxx>
> Cc: Jan Beulich <JBeulich@xxxxxxxxxx>
> ---
> arch/x86/kernel/entry_64.S | 3 ++-
> 1 files changed, 2 insertions(+), 1 deletions(-)
>
> diff --git a/arch/x86/kernel/entry_64.S b/arch/x86/kernel/entry_64.S
> index b6b2e85..20dc8e6 100644
> --- a/arch/x86/kernel/entry_64.S
> +++ b/arch/x86/kernel/entry_64.S
> @@ -310,9 +310,10 @@ ENDPROC(native_usergs_sysret64)
> movq_cfi r10, R10-RBP
> movq_cfi r11, R11-RBP
>
> - leaq -RBP(%rsp),%rdi /* arg1 for handler */
> movq_cfi rbp, 0 /* push %rbp */
> movq %rsp, %rbp
> +
> + leaq -RBP(%rsp),%rdi /* arg1 for handler */
> testl $3, CS(%rdi)
> je 1f
> SWAPGS




--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/