Re: New Gentoo install on Intel Z68/i7-2600K system hangs afterVFS:Mounted root...

From: Mark Knecht
Date: Fri Jun 17 2011 - 14:29:47 EST

On Fri, Jun 17, 2011 at 7:46 AM, Paul Hartman <paul.hartman@xxxxxxxxx> wrote:
> On Thu, Jun 16, 2011 at 10:11 PM, Mark Knecht <markknecht@xxxxxxxxx> wrote:
>> Â I've got a Windows friend who's trying to make the jump to Gentoo
>> Linux. He's purchased a new motherboard & processor which I believe
>> are part of the new 'Sandy Bridge' family:
>> I've installed Gentoo. The kernel is 2.6.38-gentoo-r6. The install
>> seemed to go fine. This is my first install from scratch after the
>> switch to OpenRC.
>> Â When the machine boots it makes it through mounting sda3 on root,
>> which looks OK to me, but then just hangs with no other messages. I've
>> posted a photo of what the screen looks like when it stops:
> Hi Mark,
> Have you tried booting with acpi=off ?
> Also, since it's a new build, have you done a memory test to be sure
> it is stable? Getting the RAM timings/voltages right is usually one of
> the biggest hurdles in building a new machine in my experiences.

We ran memtest86 for an hour. Completed a couple of passes with no
errors. Will run more later but no obvious memory problems seen.

I installed 2.6.39-gentoo-r1. No change from 2.6.38-gentoo-r6.
Stops at the same place.

I tried 2.6.39-gentoo-r1 with no kernel options, and with all
combinations of nousb and acpi=off. All 4 attempts quit at the same

This is an interesting failure that I've never seen before.
Generally either you don't find the root drive at all, or you do and
get into init where it fails somewhere. To have it just stop is quite

I've suggested that the guy with the machine try installing a
prepackaged distro, Ubuntu or Redhat, just to see if they have the
secret sauce or not. If one of those works then we're closer to
determining why my Gentoo install didn't.

I need to investigate what used to be debug through the serial port
but I think now is done through Ethernet? Maybe we can catch more of
the boot info if the error is actually earlier and we're just not
catching it because we cannot scroll back.

Any other ideas warmly welcomed.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at