Re: [PATCH] Introduce ActivePid: in /proc/self/status (v2, wasVpid:)

From: Oleg Nesterov
Date: Thu Jun 16 2011 - 10:53:06 EST

On 06/16, Louis Rilling wrote:
> On 16/06/11 15:00 +0200, Greg Kurz wrote:
> > peeking into pid->numbers.
> It ends like open-coding an optimized version of task_pid_vnr(). If the
> optimization is really important (I guess this depends on the depth of recursive
> pid namespaces), it would be better to re-write task_pid_vnr().

No, task_pid_vnr(p) is different, it should use the caller's namespace.

Just in case, I agree there is no need to optimize this code. The simpler
the better. I mentioned pid->numbers[pid->level] just to point that all
we need is task_pid() itself, there are no subtle races which need the


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at