Re: [PATCH] spi: reorganize drivers

From: Jassi Brar
Date: Sun Jun 05 2011 - 03:45:31 EST


On Sun, Jun 5, 2011 at 12:48 PM, Grant Likely <grant.likely@xxxxxxxxxxxx> wrote:
> [repost: I had a typo on the spi-devel-general mailing list address]
>
> Sort the SPI makefile and enforce the naming convention spi_*.c for
> spi drivers.
>
> This change also rolls the contents of atmel_spi.h into the .c file
> since there is only one user of that particular include file.
>
> Signed-off-by: Grant Likely <grant.likely@xxxxxxxxxxxx>
> ---
> Âdrivers/spi/Makefile      Â|  80 ++++++++-----------
> Âdrivers/spi/atmel_spi.h     | Â167 ---------------------------------------
> Âdrivers/spi/spi_ath79.c     |  Â0
> Âdrivers/spi/spi_atmel.c     | Â155 ++++++++++++++++++++++++++++++++++++
> Âdrivers/spi/spi_au1550.c    Â|  Â0
> Âdrivers/spi/spi_coldfire_qspi.c | Â Â0
> Âdrivers/spi/spi_davinci.c    |  Â0
> Âdrivers/spi/spi_dw.c      Â|  Â2
> Âdrivers/spi/spi_dw.h      Â|  Â0
> Âdrivers/spi/spi_dw_mid.c    Â|  Â2
> Âdrivers/spi/spi_dw_mmio.c    |  Â2
> Âdrivers/spi/spi_dw_pci.c    Â|  Â2
> Âdrivers/spi/spi_ep93xx.c    Â|  Â0
> Âdrivers/spi/spi_mpc512x_psc.c  |  Â0
> Âdrivers/spi/spi_mpc52xx.c    |  Â0
> Âdrivers/spi/spi_mpc52xx_psc.c  |  Â0
> Âdrivers/spi/spi_omap2_mcspi.c  |  Â0
> Âdrivers/spi/spi_omap_100k.c   |  Â0
> Âdrivers/spi/spi_omap_uwire.c  Â|  Â0
> Âdrivers/spi/spi_orion.c     |  Â0
> Âdrivers/spi/spi_pl022.c     |  Â0
> Âdrivers/spi/spi_pxa2xx.c    Â|  Â0
> Âdrivers/spi/spi_pxa2xx_pci.c  Â|  Â0
> Âdrivers/spi/spi_ti_ssp.c    Â|  Â0
> Âdrivers/spi/spi_tle62x0.c    |  Â0
> Âdrivers/spi/spi_xilinx.c    Â|  Â0

Though the spi_ prefix seems redundant considering the files are in
'spi' directory.
Just a thought, no objection.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/