Re: [PATCH 4/14] tmpfs: add shmem_read_mapping_page_gfp

From: Hugh Dickins
Date: Wed Jun 01 2011 - 13:02:40 EST


On Tue, 31 May 2011, Christoph Hellwig wrote:
> > (shmem_read_mapping_page_gfp or shmem_read_cache_page_gfp? Generally
> > the read_mapping_page functions use the mapping's ->readpage, and the
> > read_cache_page functions use the supplied filler, so I think
> > read_cache_page_gfp was slightly misnamed.)
>
> What about just shmem_read_page? It's not using the pagecache, so
> no need for the mapping or cache, and the _gfp really is just a hack
> because the old pagecache APIs didn't allow to pass the gfp flags.
> For a new API there's no need for that.

I am trying to mirror what's already there, and it's conceivable that
we'll find others who want converting from read_mapping_page() to
shmem_read_mapping_page(), so I'd rather keep the similar naming.

The _gfp() thing I'm not very keen on, but can't avoid it for i915.
If anyone else needs something here, it's likely to be without _gfp().

>
> > +static inline struct page *shmem_read_mapping_page(
> > + struct address_space *mapping, pgoff_t index)
> > +{
> > + return shmem_read_mapping_page_gfp(mapping, index,
> > + mapping_gfp_mask(mapping));
> > +}
>
> This really shouldn't be in pagemap.h. For now probably in shmem_fs.h

Okay, I can move it there, if I do the same for those shmem_...()
interfaces currently in linux/mm.h too.

Hugh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/