Re: [PATCH] KERNEL: async: Fixed an include coding style issue

From: Steven Rostedt
Date: Tue May 31 2011 - 21:11:27 EST


On Wed, 2011-06-01 at 01:51 +0100, Paul McQuade wrote:
> >From 2514174efe73e654c46e669ea2df5169a41d0130 Mon Sep 17 00:00:00 2001
> From: Paul McQuade <tungstentide@xxxxxxxxx>
> Date: Tue, 31 May 2011 20:51:55 +0100
> Subject: [PATCH] KERNEL: async: Fixed an include coding style issue
> KERNEL: trace: ftrace: Fixed an include coding style issue
>
> async:
> Added <linux/atomic.h>,<linux/ktime.h> and Removed <asm/atomic.h>.
> Added KERN_DEBUG to printk() functions.

The async changes need to be separate from the ftrace changes.

Just make two patches.

>
> ftrace:
> Removed <asm/ftrace.h> because <linux/ftrace.h> was already declared.
> Braces of struct's coding style fixed.

> Signed-off-by: Paul McQuade <tungstentide@xxxxxxxxx>
> ---
> kernel/async.c | 13 +++++++------
> kernel/trace/ftrace.c | 12 ++++--------
> 2 files changed, 11 insertions(+), 14 deletions(-)



>
> diff --git a/kernel/trace/ftrace.c b/kernel/trace/ftrace.c
> index 1ee417f..02c1cef 100644
> --- a/kernel/trace/ftrace.c
> +++ b/kernel/trace/ftrace.c
> @@ -32,7 +32,6 @@
>
> #include <trace/events/sched.h>
>
> };


>
> #define ENTRIES_PER_PAGE \
> - ((PAGE_SIZE - sizeof(struct ftrace_page)) / sizeof(struct dyn_ftrace))
> +((PAGE_SIZE - sizeof(struct ftrace_page)) / sizeof(struct dyn_ftrace))

I'm fine with all the ftrace.c changes but this one. I like the
indentation here, as it makes it easier to read that it is a
continuation of the previous line.

-- Steve


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/