Re: + vmscan-change-shrinker-api-by-passing-shrink_control-struct-fix-3.patchadded to -mm tree

From: KOSAKI Motohiro
Date: Mon May 23 2011 - 21:40:41 EST


(2011/05/21 3:59), akpm@xxxxxxxxxxxxxxxxxxxx wrote:
> The patch titled
> vmscan: fix up new shrinker API
> has been added to the -mm tree. Its filename is
> vmscan-change-shrinker-api-by-passing-shrink_control-struct-fix-3.patch
>
> Before you just go and hit "reply", please:
> a) Consider who else should be cc'ed
> b) Prefer to cc a suitable mailing list as well
> c) Ideally: find the original patch on the mailing list and do a
> reply-to-all to that, adding suitable additional cc's
>
> *** Remember to use Documentation/SubmitChecklist when testing your code ***
>
> See http://userweb.kernel.org/~akpm/stuff/added-to-mm.txt to find
> out what to do about this
>
> The current -mm tree may be found at http://userweb.kernel.org/~akpm/mmotm/
>
> ------------------------------------------------------
> Subject: vmscan: fix up new shrinker API
> From: KOSAKI Motohiro<kosaki.motohiro@xxxxxxxxxxxxxx>
>
> Current new shrinker API submission has some easy mistake. Fix it up.
>
> - remove nr_scanned field from shrink_control.
> we don't have to expose vmscan internal to shrinkers.
> - rename nr_slab_to_reclaim to nr_to_scan.
> to_reclaim is very wrong name. shrinker API allow shrinker
> don't reclaim an slab object if they were recently accessed.
> - typo: least-recently-us
>
> This patch also make do_shrinker_shrink() helper function. It
> increase code readability a bit.

Oops. I'm sorry. This patch forgot one correction. please apply
following incremental patch.




---
net/sunrpc/auth.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/net/sunrpc/auth.c b/net/sunrpc/auth.c
index 287dd25..cd6e4aa 100644
--- a/net/sunrpc/auth.c
+++ b/net/sunrpc/auth.c
@@ -330,7 +330,7 @@ rpcauth_cache_shrinker(struct shrinker *shrink, struct shrink_control *sc)
{
LIST_HEAD(free);
int res;
- int nr_to_scan = sc->nr_slab_to_reclaim;
+ int nr_to_scan = sc->nr_to_scan;
gfp_t gfp_mask = sc->gfp_mask;

if ((gfp_mask & GFP_KERNEL) != GFP_KERNEL)
--
1.7.3.1



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/