Re: [PATCH] linux/string.h: Introduce streq macro.

From: H. Peter Anvin
Date: Wed Apr 27 2011 - 14:33:45 EST


On 04/27/2011 10:49 AM, Steven Rostedt wrote:
> On Tue, 2011-04-26 at 16:45 -0300, Thiago Farina wrote:
>> This macro is arguably more readable than its variants:
>> - !strcmp(a, b)
>> - strcmp(a, b) == 0
>
> Actually, this was proposed way back in 2002 my Rusty and I did not see
> anyone arguing against it. I wonder why it never was incorporated back
> then?
>
> http://marc.info/?l=linux-kernel&m=103284339813100&w=2
>
> [ added Cc's of some of those that replied to this thread ]
>

Because !strcmp() is idiomatic C.

This is the same kind of stupidity as

#define BEGIN {
#define END }

It doesn't matter if it is more readable *to you*... learn the language,
please.

-hpa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/