Re: [PATCH v2 5/7] signal: sigprocmask() should doretarget_shared_pending()

From: Tejun Heo
Date: Mon Apr 25 2011 - 07:14:56 EST


Hey, again.

> Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx>

Acked-by: Tejun Heo <tj@xxxxxxxxxx>

But, I really think we can use some comments around here. Things
might look obvious now but it isn't very intuitive piece of code.

> +void set_current_blocked(const sigset_t *newset)
> +{
> + struct task_struct *tsk = current;
> +
> + spin_lock_irq(&tsk->sighand->siglock);
> + if (signal_pending(tsk) && !thread_group_empty(tsk)) {
> + sigset_t newblocked;
> + signandsets(&newblocked, newset, &current->blocked);

While you're touching code around here, can you please rename
signandsets() to sigandnsets()? It ain't nand!!!

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/