[PATCH 0/9] Rework command handling of AMD IOMMU driver

From: Joerg Roedel
Date: Thu Apr 07 2011 - 09:30:20 EST


Hi,

this patch-set reworks the command handling in the AMD IOMMU driver. The
functions are better named now and more clearly splitted. Some cases are
also better handled now than before, like the situation of congestion in
the command buffer.

To further increase maintainability the driver now flushes all internal
caches of the IOMMU right after it gets enabled and does not rely on
flushing individual caches before they are used.

Any feedback appreciated.

Regards,

Joerg

Diffstat:

arch/x86/include/asm/amd_iommu_proto.h | 2 -
arch/x86/include/asm/amd_iommu_types.h | 3 -
arch/x86/kernel/amd_iommu.c | 415 +++++++++++++++-----------------
arch/x86/kernel/amd_iommu_init.c | 11 +-
4 files changed, 202 insertions(+), 229 deletions(-)

Shortlog:

Joerg Roedel (9):
x86/amd-iommu: Move compl-wait command building to own function
x86/amd-iommu: Move inv-dte command building to own function
x86/amd-iommu: Cleanup inv_pages command handling
x86/amd-iommu: Cleanup completion-wait handling
x86/amd-iommu: Remove command buffer resetting logic
x86/amd-iommu: Rename iommu_flush* to domain_flush*
x86/amd-iommu: Improve handling of full command buffer
x86/amd-iommu: Rename iommu_flush_device
x86/amd-iommu: Flush all internal TLBs when IOMMUs are enabled


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/