Re: [patch 04/15] sched: throttle cfs_rq entities which exceedtheir local quota

From: Mike Galbraith
Date: Wed Mar 23 2011 - 01:09:59 EST


On Tue, 2011-03-22 at 20:03 -0700, Paul Turner wrote:

> +static void check_cfs_rq_quota(struct cfs_rq *cfs_rq)
> +{
> + if (within_bandwidth(cfs_rq))
> + return;
> +
> +

Nit: It'd be nice if classes agreed on naming convention to ease
rummaging. In rt, it's bandwidth for bean counting parameters, but the
beans are runtime. within_bandwidth() vs sched_rt_runtime_exceeded()
kinda pokes me in the eye when I look at the total. Seems to me it
should be uniformly either quota or bandwidth, and uniformly runtime.

-Mike


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/