Re: [PATCH 21/21] tcm_loop: Add multi-fabric Linux/SCSI LLD fabricmodule

From: Christoph Hellwig
Date: Mon Mar 14 2011 - 10:58:14 EST


On Mon, Mar 14, 2011 at 04:06:15AM -0700, Nicholas A. Bellinger wrote:
> drivers/target/Kconfig | 2 +
> drivers/target/Makefile | 3 +
> drivers/target/tcm_loop/Kconfig | 11 +
> drivers/target/tcm_loop/Makefile | 5 +
> drivers/target/tcm_loop/tcm_loop_configfs.c | 643 ++++++++++++++++++++++++
> drivers/target/tcm_loop/tcm_loop_core.h | 141 ++++++
> drivers/target/tcm_loop/tcm_loop_fabric.c | 472 +++++++++++++++++
> drivers/target/tcm_loop/tcm_loop_fabric_scsi.c | 574 +++++++++++++++++++++
> 8 files changed, 1851 insertions(+), 0 deletions(-)

Please descide on a naming scheme for the frontend modules. You have
tcm_loop for thise one, and just iscsi for the iscsi frontend. I'm
not sure what tcm actually stands for, but a common prefix defintively
is helpful.

And for only about 1700 lines of code I really don't see why it needs to be
split into multiple implementation files.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/