Re: [PATCH 21/20] ata_piix: add new PIIX_FLAG_* flags

From: Sergei Shtylyov
Date: Fri Feb 11 2011 - 08:05:32 EST


Hello.

On 08-02-2011 21:18, Bartlomiej Zolnierkiewicz wrote:

Turn open-coded checks in piix_set_timings() into PIIX_FLAG_* flags
per suggestion from Alan Cox.

Suggested-by: Alan Cox<alan@xxxxxxxxxxxxxxxxxxx>
Signed-off-by: Bartlomiej Zolnierkiewicz<bzolnier@xxxxxxxxx>

[...]

Index: b/drivers/ata/ata_piix.c
===================================================================
--- a/drivers/ata/ata_piix.c
+++ b/drivers/ata/ata_piix.c
@@ -133,6 +133,8 @@ enum {
PIIX_FLAG_CHECKINTR = (1<< 28), /* make sure PCI INTx enabled
*/
PIIX_FLAG_SIDPR = (1<< 29), /* SATA idx/data pair regs */
+ PIIX_FLAG_NO_SITRE = (1<< 30), /* no SITRE register */

The register in question is called SIDETIM, SITRE is a bit that enables
its use.

ICH4-M databook that I have at hand (Intel IDE PRM seems to be gone
from Intel's website, though I'm sure I have a backup _somewhere_) it

If you mean ICH IDE Controller PRM (29860004.pdf), it indeed calls the register *SITR* (yet it has SIDETIM mentioned in the table 37 :-). Intel seems not very consistent in its documentation. :-)

Thanks,
Bartlomiej

WBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/