Re: [PATCH] ath3k: Avoid duplication of code

From: Gustavo F. Padovan
Date: Wed Feb 02 2011 - 11:37:16 EST


Hi Rogério,

* Rogério Brito <rbrito@xxxxxxxxxx> [2011-01-28 20:18:10 -0200]:

>
> Hi.
>
> In commit 86e09287e4f8c81831b4d4118a48597565f0d21b, to reduce memory
> usage, the functions of the ath3k module were rewritten to release the
> firmware blob after it has been loaded (successfully or not).
>
> The resuting code has some redundancy and the compiler can potentially
> produce better code if we omit a function call that is unconditionally
> executed in
>
> ,----
> | if (ath3k_load_firmware(udev, firmware)) {
> | release_firmware(firmware);
> | return -EIO;
> | }
> | release_firmware(firmware);
> |
> | return 0;
> | }
> `----
>
> It may also be argued that the rewritten code becomes easier to read,
> and also to see the code coverage of the snippet in question.
>
>
> Signed-off-by: Rogério Brito <rbrito@xxxxxxxxxx>
> Cc: Alexander Holler <holler@xxxxxxxxxxxxx>
> Cc: "Gustavo F. Padovan" <padovan@xxxxxxxxxxxxxx>
> Cc: Miguel Ojeda <miguel.ojeda.sandonis@xxxxxxxxx>

Please send me your patch in a 'git format-patch' way, so I can apply it
without having to edit the commit message. And add "Bluetooth:" to the
beginning of the commit title.

>
> ---
>
> Thanks for all the feedback on the previous patches. The one that didn't
> compile before was sent without a hunk. This time everything all the
> basics are verified.
>
>
> diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
> index a126e61..42fa531 100644
> --- a/drivers/bluetooth/ath3k.c
> +++ b/drivers/bluetooth/ath3k.c
> @@ -106,6 +106,7 @@ static int ath3k_probe(struct usb_interface *intf,
> {
> const struct firmware *firmware;
> struct usb_device *udev = interface_to_usbdev(intf);
> + int ret;
>
> BT_DBG("intf %p id %p", intf, id);
>
> @@ -116,13 +117,10 @@ static int ath3k_probe(struct usb_interface *intf,
> return -EIO;
> }
>
> - if (ath3k_load_firmware(udev, firmware)) {
> - release_firmware(firmware);
> - return -EIO;
> - }
> + ret = ath3k_load_firmware(udev, firmware);
> release_firmware(firmware);
>
> - return 0;
> + return ret ? -EIO : 0;

just return ret;
It is enough.

Regards,

--
Gustavo F. Padovan
http://profusion.mobi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/