Re: [PATCH 04/11] x86/dtb: add irq host abstraction

From: Sebastian Andrzej Siewior
Date: Fri Nov 26 2010 - 09:19:44 EST


Jon Loeliger wrote:

+struct irq_host {
+ int (*xlate)(struct irq_host *h, const u32 *intspec, u32 intsize,
+ u32 *out_hwirq, u32 *out_type);
+ void *priv;
+ struct device_node *controller;
+ struct list_head l;
+};

I thought there was an intent and desire to rename the irq_host
as irq_domain.

jdl

AFAIK Benh was thinking about renaming it. I don't know if this is still
the case or when he intends to do so. Once he does so, this can be renamed
as well.

Sebastian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/