Re: [PATCH 2/3] ftrace/x86: Add support for C version of recordmcount

From: Ingo Molnar
Date: Thu Oct 14 2010 - 22:51:07 EST



* Steven Rostedt <rostedt@xxxxxxxxxxx> wrote:

> From: Steven Rostedt <srostedt@xxxxxxxxxx>
>
> This patch adds the support for the C version of recordmcount and
> compile times show ~ 12% improvement.

I reported this recordmcount performance problem 2 years ago. Better
later than never i guess.

> +ifdef CONFIG_DYNAMIC_FTRACE
> + ifdef CONFIG_HAVE_C_MCOUNT_RECORD
> + BUILD_C_RECORDMCOUNT := y
> + export BUILD_C_RECORDMCOUNT

> --- a/arch/x86/Kconfig
> +++ b/arch/x86/Kconfig
> @@ -33,6 +33,7 @@ config X86
> select HAVE_KRETPROBES
> select HAVE_OPTPROBES
> select HAVE_FTRACE_MCOUNT_RECORD
> + select HAVE_C_MCOUNT_RECORD

The naming is inconsistent here - it should be HAVE_C_RECORDMCOUNT, like
the build variable has, and like the utility is called. If we are going
to add this flag to most architectures we should name it consistently.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/