Re: [PATCH 4/8] v2 Allow memory block to span multiple memorysections

From: Dave Hansen
Date: Mon Sep 27 2010 - 19:55:31 EST


On Mon, 2010-09-27 at 14:25 -0500, Nathan Fontenot wrote:
> +static inline int base_memory_block_id(int section_nr)
> +{
> + return section_nr / sections_per_block;
> +}
...
> - mutex_lock(&mem_sysfs_mutex);
> -
> - mem->phys_index = __section_nr(section);
> + scn_nr = __section_nr(section);
> + mem->phys_index = base_memory_block_id(scn_nr) * sections_per_block;

I'm really regretting giving this variable such a horrid name. I suck.

I think this is correct now:

mem->phys_index = base_memory_block_id(scn_nr) * sections_per_block;
mem->phys_index = section_nr / sections_per_block * sections_per_block;
mem->phys_index = section_nr

Since it gets exported to userspace this way:

> +static ssize_t show_mem_start_phys_index(struct sys_device *dev,
> struct sysdev_attribute *attr, char *buf)
> {
> struct memory_block *mem =
> container_of(dev, struct memory_block, sysdev);
> - return sprintf(buf, "%08lx\n", mem->phys_index / sections_per_block);
> + unsigned long phys_index;
> +
> + phys_index = mem->start_phys_index / sections_per_block;
> + return sprintf(buf, "%08lx\n", phys_index);
> +}

The only other thing I'd say is that we need to put phys_index out of
its misery and call it what it is now: a section number. I think it's
OK to call them "start/end_section_nr", at least inside the kernel. I
intentionally used "phys_index" terminology in sysfs so that we _could_
eventually do this stuff and break the relationship between sections and
the sysfs dirs, but I think keeping the terminology around inside the
kernel is confusing now.

-- Dave

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/