Re: [patch 4/6] jbd: remove dependency on __GFP_NOFAIL

From: David Rientjes
Date: Mon Aug 23 2010 - 18:22:52 EST


On Mon, 23 Aug 2010, Andrew Morton wrote:

> > So do
> > you think that we should keep __GFP_NOFAIL as long as all callers are not
> > able to handle allocation failures in more reasonable way?
>
> The concept should be encapsulated in _some_ centralised fashion.
>
> Helper functions would work as well as __GFP_NOFAIL, and will move any
> runtime cost away from the good code and push it onto the bad code.
>

There's no runtime cost on the bad code, the calls never loop since the
page allocator already loops itself. Regardless, I'll add a helper
function to include/linux/gfp.h to do this with a WARN_ON_ONCE() inside
the loop in case any order > PAGE_ALLOC_COSTLY_ORDER callers are ever
added (and I really hope nobody merges those).
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/