Re: [patch 1/6] md: remove dependency on __GFP_NOFAIL

From: David Rientjes
Date: Mon Aug 23 2010 - 16:13:30 EST


On Mon, 23 Aug 2010, Pekka Enberg wrote:

> > Hows about you add a helper function
> >
> >        void *[kmalloc|alloc_page]_retrying_forever_because_i_suck(lots of args)
> >
> > then convert the callsites to use that, then nuke __GFP_NOFAIL?
>
> I'd prefer killing off __GFP_NOFAIL properly :-)
>

And how is this not done properly if it's not even needed for any of the
allocations in this patchset since the page allocator loops forever for
their orders and context? (This is why we don't need to add __GFP_NOWARN
in its place.)

This is a cleanup patchset to remove the unnecessary use of __GFP_NOFAIL,
there _are_ GFP_KERNEL | __GFP_NOFAIL allocations that need to be
addressed in phase three.