Re: [patch 1/6] md: remove dependency on __GFP_NOFAIL

From: Andrew Morton
Date: Mon Aug 23 2010 - 15:26:33 EST


On Mon, 16 Aug 2010 19:57:51 -0700 (PDT)
David Rientjes <rientjes@xxxxxxxxxx> wrote:

> Removes the dependency on __GFP_NOFAIL by looping indefinitely in the
> caller.
>
> Signed-off-by: David Rientjes <rientjes@xxxxxxxxxx>
> ---
> drivers/md/dm-region-hash.c | 8 ++++++--
> 1 files changed, 6 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/md/dm-region-hash.c b/drivers/md/dm-region-hash.c
> --- a/drivers/md/dm-region-hash.c
> +++ b/drivers/md/dm-region-hash.c
> @@ -289,8 +289,12 @@ static struct dm_region *__rh_alloc(struct dm_region_hash *rh, region_t region)
> struct dm_region *reg, *nreg;
>
> nreg = mempool_alloc(rh->region_pool, GFP_ATOMIC);
> - if (unlikely(!nreg))
> - nreg = kmalloc(sizeof(*nreg), GFP_NOIO | __GFP_NOFAIL);
> + if (unlikely(!nreg)) {
> + /* FIXME: this may potentially loop forever */
> + do {
> + nreg = kmalloc(sizeof(*nreg), GFP_NOIO);
> + } while (!nreg);
> + }
>
> nreg->state = rh->log->type->in_sync(rh->log, region, 1) ?
> DM_RH_CLEAN : DM_RH_NOSYNC;

erm.

The reason for adding GFP_NOFAIL in the first place was my observation
that the kernel contained lots of open-coded retry-for-ever loops.

All of these are wrong, bad, buggy and mustfix. So we consolidated the
wrongbadbuggymustfix concept into the core MM so that miscreants could
be easily identified and hopefully fixed.

I think that simply undoing that change is a bad idea - it allows the
wrongbadbuggymustfix code to hide from view.

The correct way to remove __GFP_NOFAIL is to fix the
wrongbadbuggymustfix code properly.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/