Re: [PATCH 1/4] irq: rename IRQF_TIMER to IRQF_NO_SUSPEND
From: Thomas Gleixner
Date: Thu Jul 29 2010 - 04:49:59 EST
On Wed, 28 Jul 2010, Ian Campbell wrote:
> Continue to provide IRQF_TIMER as an alias to IRQF_NO_SUSPEND since I
> think it is worth preserving the nice self-documenting name (where it
> is used appropriately). It also avoid needing to patch all the many
> users who are using the flag for an actual timer interrupt.
I'm not happy about the alias. What about:
#define __IRQF_TIMER 0x00000200
#define IRQF_NO_SUSPEND 0x00000400
#define IRQF_TIMER (__IRQF_TIMER | IRQF_NO_SUSPEND)
Thanks,
tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/