Getting error message "Cannot read inode bitmap". Someone able tohelp?

From: Manuel Reimer
Date: Tue Jul 27 2010 - 17:31:48 EST


I tried to restore data from a broken NAS device. This small box contained a embedded linux system and two 1TB hard drives.

After some tries, I managed to connect both drives via mdadm and was able to mount this raid as XFS.

Now I connected a brand new eSATA drive to this PC and started to copy the data (about 700 Gigabytes). Target disk was 1TB, so enough space to hold the source data.

With my first try (ext2 on target disk) I got the error "Cannot read inode bitmap". The kernel reported this error for the *target* device (the brand new SATA hard drive). I did a second try and reformated the target drive to ext3 and, again, I got the same error. So I installed "smartmontools" into my running live system and checked the drive. The new drive has no "reallocated sectors" but several read errors (about 500).

The worst thing about this is, that a diff between source and target showed many files differing, so I didn't just get errors, but I also have bad data on the target disk. This is a pretty *unstable* disc behaviour...

The copy program, I used, was "cp" from busybox.

What should I check to find the reason for this errors? Is it really possible that a brand new disc, which doesn't have conspicuous smart values, is the reason for this problem? May the eSATA disc enclosure (has a small circuit to also offer USB access) be the reason?

The log entries, I could get via dmesg, are available here:

Thank you very much in advance


Manuel Reimer

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at