Re: [PATCH] Staging: vt6656: Change the define FALSE and TRUE to the lower case variant.

From: Roel Van Nyen
Date: Tue Jul 13 2010 - 05:36:19 EST


2010/7/13 Bernd Petrovitsch <bernd@xxxxxxxxxxxxxxxxxxx>
>
> Hi!
>
> On Mon, 2010-07-12 at 23:26 +0200, Roel Van Nyen wrote:
> [...]
> > @@ -178,7 +178,7 @@ vMgrDecodeBeacon(
> >              break;
> >          case WLAN_EID_RSN_WPA:
> >              if (pFrame->pRSNWPA == NULL) {
> > -                if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem) == TRUE)
> > +                if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem) == true)
> >                      pFrame->pRSNWPA = (PWLAN_IE_RSN_EXT)pItem;
> >              }
> >              break;
>
> Am I the only one who thinks that this should better be
> ----  snip  ----
> @@ -178,7 +178,7 @@ vMgrDecodeBeacon(
>             break;
>         case WLAN_EID_RSN_WPA:
>             if (pFrame->pRSNWPA == NULL) {
> -                if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem) == TRUE)
> +                if (WPAb_Is_RSN((PWLAN_IE_RSN_EXT)pItem))
>                     pFrame->pRSNWPA = (PWLAN_IE_RSN_EXT)pItem;
>             }
>             break;
> ----  snip  ----
> - if only for readability and understandability?
>
>        Bernd
> --
> Bernd Petrovitsch                  Email : bernd@xxxxxxxxxxxxxxxxxxx
>                     LUGA : http://www.luga.at
>

Hi!

I think from a readability and understandability standpoint == true is
very clear, anyone who reads it will explicitly understand the
meaning.
The goal of my patch is to remove the defines from the ttype.h so that
at some time ttype.h can be removed.

Any more pros or cons for the == true ?
Roel
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/