Re: [PATCH -V14 0/11] Generic name to handle and open by handle syscalls

From: Miklos Szeredi
Date: Thu Jul 08 2010 - 07:53:23 EST


On Thu, 08 Jul 2010, Aneesh Kumar K. V wrote:
> How about adding mnt_id to the handle ? Documentation file says it is
> unique
>
> (1) mount ID: unique identifier of the mount (may be reused after umount)
>
> I also updated (/proc/self/mountinfo) to carry the optional uuid field
> With the below patch i get in /proc/self/mountinfo
>
> 13 1 253:0 / / rw,relatime,uuid:9b5af62a-a34a-43f6-a5bb-1cc22d97e862 - ext3 /dev/root rw,errors=continue,barrier=0,data=writeback
>
> And the handle returns the value 13 in mnt_id field. We should able to
> lookup mountinfo with mnt_id and find the corresponding uuid.
>
> diff --git a/fs/namespace.c b/fs/namespace.c
> index 88058de..498bd9a 100644
> --- a/fs/namespace.c
> +++ b/fs/namespace.c
> @@ -871,6 +871,9 @@ static int show_mountinfo(struct seq_file *m, void *v)
> if (IS_MNT_UNBINDABLE(mnt))
> seq_puts(m, " unbindable");
>
> + /* print the uuid */
> + seq_printf(m, ",uuid:%pU", mnt->mnt_sb->s_uuid);
> +

This should be

seq_printf(m, " uuid:%pU", mnt->mnt_sb->s_uuid);

Thanks,
Miklos
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/