Re: [PATCH 03/25] lmb: Print new doubled array location info

From: Bjorn Helgaas
Date: Tue Jun 29 2010 - 16:57:58 EST


On Tuesday, June 29, 2010 02:03:21 pm Yinghai Lu wrote:
> On 06/29/2010 10:44 AM, Bjorn Helgaas wrote:
> > On Tuesday, June 22, 2010 11:26:32 am Yinghai Lu wrote:
> >> + if (lmb_debug)
> >> + pr_info("lmb: %s array is doubled to %ld at %llx - %llx",
> >> + lmb_type_name(type), type->max * 2, (u64)addr, (u64)addr + new_size);
> >
> > Please print this memory range the same way we print resources, e.g.,
> > "%#010llx-%#010llx", with "addr" and "addr + new_size - 1".
>
> ok, I will put # for 0x.
>
> but i like to have
>
> xxx - yyy : to include end
> [xxx, yyy - 1]
>
> just like current e820 print out.
> and it would be more readable without too many ffff

I think it's stupid to use two different conventions for printing
address ranges. That just makes extra mental work for people
comparing e820 ranges with %pR resources.

I don't personally care that much whether we pick the convention of
including the end (like the current e820 output) or the convention of
excluding it (like %pR and /proc/iomem do), but whatever we pick, we
should use it consistently.

To me, the fact that /proc/iomem is user-visible and excludes the end
is a pretty strong argument for adopting that convention.

And I think you should remove the extra spaces in "xxx - yyy".
There's no reason to be different when we could be consistent.

Bjorn
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/