[PATCH] Use IBFT_SIGN instead of open-coding the search string.

From: Peter Jones
Date: Wed May 12 2010 - 10:25:42 EST


We define IBFT_SIGN to "iBFT"; may as well use it.

Signed-of-by: Peter Jones <pjones@xxxxxxxxxx>
---
drivers/firmware/iscsi_ibft_find.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/drivers/firmware/iscsi_ibft_find.c b/drivers/firmware/iscsi_ibft_find.c
index 82a7a15..2192456 100644
--- a/drivers/firmware/iscsi_ibft_find.c
+++ b/drivers/firmware/iscsi_ibft_find.c
@@ -100,7 +100,7 @@ unsigned long __init find_ibft_region(unsigned long *sizep)
if (!ibft_addr)
acpi_table_parse(ACPI_SIG_IBFT, acpi_find_ibft);
if (!ibft_addr)
- acpi_table_parse("iBFT", acpi_find_ibft);
+ acpi_table_parse(IBFT_SIGN, acpi_find_ibft);
#endif /* CONFIG_ACPI */

/* iBFT 1.03 section 1.4.3.1 mandates that UEFI machines will
--
1.7.0.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/