Re: [PATCH 3/3] Stop tracing on a schedule bug

From: Chase Douglas
Date: Thu Apr 15 2010 - 23:52:47 EST


On Thu, Apr 15, 2010 at 4:50 PM, Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
> On Thu, 15 Apr 2010, Chase Douglas wrote:
>> On Thu, Apr 15, 2010 at 4:01 PM, Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
>> > On Thu, 15 Apr 2010, Chase Douglas wrote:
>> >> On Thu, Apr 15, 2010 at 2:03 PM, Frederic Weisbecker <fweisbec@xxxxxxxxx> wrote:
>> >> > On Wed, Apr 14, 2010 at 12:20:16PM -0400, Chase Douglas wrote:
>> >> >> This change adds a tracing_off_event() call to stop tracing on schedule
>> >> >> bugs unless tracing_off=none was specified on the commandline.
>> >> >>
>> >> >> Signed-off-by: Chase Douglas <chase.douglas@xxxxxxxxxxxxx>
>> >> >> ---
>> >> >>  kernel/sched.c |    2 ++
>> >> >>  1 files changed, 2 insertions(+), 0 deletions(-)
>> >> >>
>> >> >> diff --git a/kernel/sched.c b/kernel/sched.c
>> >> >> index 6af210a..439f036 100644
>> >> >> --- a/kernel/sched.c
>> >> >> +++ b/kernel/sched.c
>> >> >> @@ -3590,6 +3590,8 @@ static noinline void __schedule_bug(struct task_struct *prev)
>> >> >>  {
>> >> >>       struct pt_regs *regs = get_irq_regs();
>> >> >>
>> >> >> +     tracing_off_event(TRACE_EVENT_BUG);
>> >> >> +
>> >> >>       printk(KERN_ERR "BUG: scheduling while atomic: %s/%d/0x%08x\n",
>> >> >>               prev->comm, prev->pid, preempt_count());
>> >> >
>> >> >
>> >> >
>> >> > I would rather call that a TRACE_EVENT_WARN as this is what happens: we
>> >> > warn but we continue.
>> >>
>> >> I tend to think of the TRACE_EVENT_* as an indication of severity and
>> >> whether we want to stop the trace by default. From a distro
>> >> standpoint, the likelihood that we want to continue tracing after a
>> >> __schedule_bug is pretty low. It's easiest if we don't have to tell
>> >
>> > Well, scheduling while atomic is a BUG, but one of the category which
>> > allows the kernel to continue. So in fact it's treated like a WARN_ON.
>> > So the tracing_off_event() qualifier should be *_WARN.
>> >
>> > That's independent of the question whether you want to stop tracing in
>> > that very case. Though I agree that the tracer should stop here.
>>
>> We seem to be agreeing on the functionality. The disagreement seems to
>> be in the macro name/functionality mapping. However, the name of the
>> function itself is *_bug. I don't see how things are clearer or more
>> useful by inserting a *_WARN level macro in a *_bug named function.
>
> Care to read what I wrote ? Again:

I misunderstood what you wrote. I thought you were agreeing that the
tracing should stop by default in __schedule_bug. I now realize you
meant that you agree it should be possible to stop it, but it should
not be the default behavior. Sorry for the confusion.

I will change the event to be a *_WARN type.

-- Chase
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/