Re: [PATCH 5/6] KVM MMU: reduce kvm_mmu_page size

From: Xiao Guangrong
Date: Mon Apr 12 2010 - 07:14:28 EST




Avi Kivity wrote:
> On 04/12/2010 11:05 AM, Xiao Guangrong wrote:
>> 'multimapped' and 'unsync' in 'struct kvm_mmu_page' are just indication
>> field, we can use flag bits instand of them
>>
>> @@ -202,9 +202,10 @@ struct kvm_mmu_page {
>> * in this shadow page.
>> */
>> DECLARE_BITMAP(slot_bitmap, KVM_MEMORY_SLOTS +
>> KVM_PRIVATE_MEM_SLOTS);
>> - int multimapped; /* More than one parent_pte? */
>> int root_count; /* Currently serving as active root */
>> - bool unsync;
>> + #define MMU_PAGE_MULTIMAPPED 0x1 /* More than one
>> parent_pte? */
>> + #define MMU_PAGE_UNSYNC 0x2
>> + unsigned int flags;
>> unsigned int unsync_children;
>> union {
>>
>
> Please just use bool for multimapped. If we grow more than 4 flags, we
> can use 'bool flag : 1;' to reduce space while retaining readability.
>

Yeah, good idea, i'll fix it in the next version

Thanks,
Xiao
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/