Re: kmemleak_scan_area

From: Catalin Marinas
Date: Wed Mar 31 2010 - 08:07:10 EST


Sachin Pandhare <sachinpandhare@xxxxxxxxx> wrote:
> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
> well as a function.
> e.g.:
> - struct kmemleak_scan_area {
> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
>
> Do you think it is a good to have it like that?

Does it cause any problems? I think C has different namespaces for types
and functions, so they should not collide. I agree that from a
readability perspective, it would be better if they are named
differently (like kmemleak_scan_area_node :)).

--
Catalin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/