Re: [PATCH 25/35] move round_up/down to kernel.h

From: Joe Perches
Date: Sat Feb 13 2010 - 13:49:49 EST


On Wed, 2010-02-10 at 01:20 -0800, Yinghai Lu wrote:
> diff --git a/include/linux/kernel.h b/include/linux/kernel.h
> index 1221d23..7f07074 100644
> --- a/include/linux/kernel.h
> +++ b/include/linux/kernel.h
> @@ -44,6 +44,16 @@ extern const char linux_proc_banner[];
[]
> +#define __round_mask(x, y) ((__typeof__(x))((y)-1))
> +#define round_up(x, y) ((((x)-1) | __round_mask(x, y))+1)
> +#define round_down(x, y) ((x) & ~__round_mask(x, y))
> +
> #define FIELD_SIZEOF(t, f) (sizeof(((t*)0)->f))
> #define DIV_ROUND_UP(n,d) (((n) + (d) - 1) / (d))
> #define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))

Having both roundup and round_up in kernel.h is a
near guarantee for a future incorrect use.

Can't you use a different name for this?

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/