Re: [PATCH 1/7] sched: Use for_each_bit

From: Alexey Dobriyan
Date: Sun Jan 31 2010 - 07:06:19 EST


On Sun, Jan 31, 2010 at 1:53 PM, Akinobu Mita <akinobu.mita@xxxxxxxxx> wrote:
>  #define for_each_cpupri_active(array, idx)                    \
> -  for (idx = find_first_bit(array, CPUPRI_NR_PRIORITIES);     \
> -       idx < CPUPRI_NR_PRIORITIES;                            \
> -       idx = find_next_bit(array, CPUPRI_NR_PRIORITIES, idx+1))
> +       for_each_bit(idx, array, CPUPRI_NR_PRIORITIES)

It should be called for_each_set_bit().
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/