Re: [PATCH -v5 0/38] x86: not use bootmem for x86

From: Yinghai Lu
Date: Mon Jan 25 2010 - 21:16:31 EST


On 01/25/2010 04:40 PM, H. Peter Anvin wrote:
> I have been looking at this patchset and tried it out; it has a build
> failure because of a naming conflict:
>
> /home/hpa/kernel/linux-2.6-tip.range/drivers/pci/hotplug/ibmphp_res.c:43: error:
> conflicting types for ‘add_range’
> /home/hpa/kernel/linux-2.6-tip.range/include/linux/range.h:9: note:
> previous declaration of ‘add_range’ was here
>
> "add_range" is static.
>
> This makes me concerned that the naming is too generic. In particular,
> we tend to prefer naming of the type subsystem_function(), so in this
> case range_add() might be a more suitable naming scheme.

ibmphp_res.c:static int add_range (int type, struct range_node *, struct bus_node *);
ibmphp_res.c: add_range (flag, newrange, newbus);
ibmphp_res.c:static int add_range (int type, struct range_node *range, struct bus_node *bus_cur)
ibmphp_res.c: * the range numbers that they correspond to. It was called from add_range fnc
ibmphp_res.c: add_range (IO, range, bus_sec);
ibmphp_res.c: add_range (MEM, range, bus_sec);
ibmphp_res.c: add_range (PFMEM, range, bus_sec);

can we change name in ibmphp_res.c instead. that is local one.

>
> I'm going to spend more time on this patchset.
>
Thanks

Yinghai
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/