[patch 00/23] locking: name space cleanup and -rt spinlock annotation

From: Thomas Gleixner
Date: Sun Dec 06 2009 - 13:02:19 EST


PREEMPT_RT needs to annotate spinlocks which cannot be converted to
sleeping locks.

The best name raw_spinlock is already taken by the low level
architecture implementations. We tried to come up with a good name for
those locks but none of the naming suggestions was really great.

Linus finally suggested to cleanup the name space and rename the low
level locks in the architecture code to arch_spinlock.

The following patch series contains:
- the name space cleanup
- the new raw_spinlock implementation
- annotation of the most important locks

A git version of the series can be found here:

git://git.kernel.org/pub/scm/linux/kernel/git/tip/linux-2.6-tip rt/locking

Thanks,

tglx



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/