Re: [PATCH 04/41] VFS: Remove unnecessary micro-optimization in cached_lookup()

From: Erez Zadok
Date: Sun Nov 29 2009 - 21:08:27 EST


In message <1256152779-10054-5-git-send-email-vaurora@xxxxxxxxxx>, Valerie Aurora writes:
> From: Jan Blunck <jblunck@xxxxxxx>
>
> d_lookup() takes rename_lock which is a seq_lock. This is so cheap
> it's not worth calling lockless __d_lookup() first from
> cache_lookup(). Rename cached_lookup() to cache_lookup() while we're
> there.

Val, this is another patch unrelated to union mounts, an
optimization/simplification of the VFS code. I think you need to try and
push such VFS patches upstream more quickly, so as to reduce the set of UM
patches you have to maintain.

> Signed-off-by: Jan Blunck <jblunck@xxxxxxx>
> Signed-off-by: Valerie Aurora <vaurora@xxxxxxxxxx>
> ---
> fs/namei.c | 13 ++++---------
> 1 files changed, 4 insertions(+), 9 deletions(-)
>
> diff --git a/fs/namei.c b/fs/namei.c
> index e334f25..9c9ecfa 100644
> --- a/fs/namei.c
> +++ b/fs/namei.c
> @@ -404,15 +404,10 @@ do_revalidate(struct dentry *dentry, struct nameidata *nd)
> * Internal lookup() using the new generic dcache.
> * SMP-safe
> */
> -static struct dentry * cached_lookup(struct dentry * parent, struct qstr * name, struct nameidata *nd)
> +static struct dentry *cache_lookup(struct dentry *parent, struct qstr *name,
> + struct nameidata *nd)
> {
> - struct dentry * dentry = __d_lookup(parent, name);
> -
> - /* lockess __d_lookup may fail due to concurrent d_move()
> - * in some unrelated directory, so try with d_lookup
> - */
> - if (!dentry)
> - dentry = d_lookup(parent, name);
> + struct dentry *dentry = d_lookup(parent, name);
>
> if (dentry && dentry->d_op && dentry->d_op->d_revalidate)
> dentry = do_revalidate(dentry, nd);
> @@ -1191,7 +1186,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
> goto out;
> }
>
> - dentry = cached_lookup(base, name, nd);
> + dentry = cache_lookup(base, name, nd);
> if (!dentry) {
> struct dentry *new;
>
> --
> 1.6.3.3
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at http://vger.kernel.org/majordomo-info.html

Erez.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/