Re: [PATCH 2/4] vmscan: make lru_index() helper function

From: Vincent Li
Date: Fri Nov 27 2009 - 01:02:55 EST



Hi KOSAKI,

On Fri, 27 Nov 2009, KOSAKI Motohiro wrote:

> Current lru calculation (e.g. LRU_ACTIVE + file * LRU_FILE) is a bit
> ugly.
> To make helper function improve code readability a bit.
>
> Signed-off-by: KOSAKI Motohiro <kosaki.motohiro@xxxxxxxxxxxxxx>
> ---
> mm/vmscan.c | 25 ++++++++++++++-----------
> 1 files changed, 14 insertions(+), 11 deletions(-)
>
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index a58ff15..7e0245d 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -156,6 +156,16 @@ static unsigned long zone_nr_lru_pages(struct zone *zone,
> return zone_page_state(zone, NR_LRU_BASE + lru);
> }
>
> +static inline enum lru_list lru_index(int active, int file)
> +{
> + int lru = LRU_BASE;
> + if (active)
> + lru += LRU_ACTIVE;
> + if (file)
> + lru += LRU_FILE;
> +
> + return lru;
> +}
>
> @@ -1373,10 +1378,8 @@ static void shrink_active_list(unsigned long nr_pages, struct zone *zone,
> */
> reclaim_stat->recent_rotated[file] += nr_rotated;
>
> - move_active_pages_to_lru(zone, &l_active,
> - LRU_ACTIVE + file * LRU_FILE);
> - move_active_pages_to_lru(zone, &l_inactive,
> - LRU_BASE + file * LRU_FILE);
> + move_active_pages_to_lru(zone, &l_active, lru_index(1, file));
> + move_active_pages_to_lru(zone, &l_inactive, lru_index(0, file));

How about:
move_active_pages_to_lru(zone, &l_active, lru_index(LRU_ACTIVE, file));
move_active_pages_to_lru(zone, &l_inactive, lru_index(LRU_BASE, file));
?

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/