Re: [PATCH 1/1] MM: slqb, fix per_cpu access

From: Rusty Russell
Date: Wed Nov 04 2009 - 02:46:19 EST


On Tue, 3 Nov 2009 02:01:41 am Jiri Slaby wrote:
> >> - struct delayed_work *cache_trim_work = &per_cpu(cache_trim_work, cpu);
> >> + struct delayed_work *_cache_trim_work = &per_cpu(cache_trim_work, cpu);
> >>
> >> /*
> >> * When this gets called from do_initcalls via cpucache_init(),
> >> * init_workqueues() has already run, so keventd will be setup
> >> * at that time.
> >> */
> >> - if (keventd_up() && cache_trim_work->work.func == NULL) {
> >> - INIT_DELAYED_WORK(cache_trim_work, cache_trim_worker);
> >> - schedule_delayed_work_on(cpu, cache_trim_work,
> >> + if (keventd_up() && _cache_trim_work->work.func == NULL) {
> >> + INIT_DELAYED_WORK(_cache_trim_work, cache_trim_worker);
> >> + schedule_delayed_work_on(cpu, _cache_trim_work,
> >> __round_jiffies_relative(HZ, cpu));
> >
> > How about calling the local var "trim"?
> >
> > This actually makes the code more readable, IMHO.
>
> Please ignore this version of the patch. After this I sent a new one
> which changes the global var name.

OK, sure. It's not worth changing unless you were doing a rename anyway.

> So the local variable is untouched there. If you want me to perform the
> cleanup, let me know. In any case I'd make it trim_work instead of trim
> which makes more sense to me.

This is getting pedantic and marginal, but the word "work" already appears
everywhere this var is used. Either "XXX->work", or "INIT_DELAYED_WORK(XXX"
or "scheduled_delayed_work_on(cpu, XXX".

That's why I think the word "work" in unnecessary.

Hope that clarifies why I preferred "trim".
Rusty.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/