[PATCH] drm: replace DRM_COPY macro w/ a function
From: Andres Salomon
Date: Tue Nov 03 2009 - 15:10:23 EST
On Mon, 2 Nov 2009 23:41:24 -0800
Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:
> On Mon, 19 Oct 2009 01:37:08 -0400 Andres Salomon
> <dilinger@xxxxxxxxxxxxxxx> wrote:
> > There are a few more macros in drmP.h that are unused;
> > DRM_GET_PRIV_SAREA, DRM_ARRAY_SIZE, and DRM_WAITCOUNT can go away
> > completely.
> > Unfortunately, DRM_COPY is still used in one place, but we can at
> > least move it to where it's used. It's an awful looking macro..
> It would have been nice to fix the (valid) checkpatch warnings while
> you were there.
How about I do one better and replace the macro w/ a function?