Re: [linux-pm] intermittent suspend problem again

From: Ferenc Wagner
Date: Sun Nov 01 2009 - 16:54:57 EST

"Rafael J. Wysocki" <rjw@xxxxxxx> writes:

> On Saturday 31 October 2009, Ferenc Wagner wrote:
>> Heh, maybe, but the version compiled from Rafael's git tree prints the
>> ratio all right, and its value is even positive and less than 1. So I
>> confirm that the ratio issue is fixed. I'll be running with this
>> version from now on, and if it exhibits the same original issue, I'll
>> switch to shutdown mode and gather some experience running that.
> Well, the problem you reported is a kernel issue and switching to the newer
> user space is not likely to help.

Well, I haven't had my hopes overly high, but wanted to have a concrete
baseline. So: with the new s2disk I got a freeze again after S|. After
a manual power off and a successful resume, I switched to shutdown mode
and hibernated again, and got the exact same freeze (apart from a
slightly different image size). Power off, resume, switch to reboot
mode, hibernate, and this worked. Switch back to shutdown, now that
worked as well... Eh. In my earlier bug report I think I noted that
after such a hibernation failure a straight shutdown didn't power off
the computer as it otherwise does, which feels consistent with the

With the uswsusp 0.7, a typical freeze looked like this:

s2disk: Snapshotting system
s2disk: System snapshot ready. Preparing to write
s2disk: Image size: 240872 kilobytes
s2disk: Free swap: 1333596 kilobytes
s2disk: Saving 60217 image data pages (press backspace to abort) ... 100% done (60217 pages)
s2disk: Compression ratio -63208.85

With the new version the ratio is 0.42 with similar numbers, which
sounds sane at least. However, 60217 * 4 = 240868 = 240872 - 4, wasn't
the number of saved pages one off? The new version seems to get this
right, though.

Now something else, which may or may not be related. I supervise a
computing farm running a very old OS: Debian Sarge. The kernel was
somewhat newer: 2.6.24 until recently, when new machines arrived to the
lab, which couldn't boot that 2.6.24 kernel. So I upgraded to 2.6.31,
which works quite well, apart from one thing: halt doesn't power off the
machines anymore. All the same under 2.6.32-rc5: they simply freeze
after reaching halt -d -f -i -h -p in the shutdown sequence.

I'm pretty much stumped here, but will try to get some SysRq dumps out
of these machines at least.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at