Re: [trivial PATCH] fix typo in nmi.c of apic

From: Luming Yu
Date: Mon Oct 26 2009 - 23:50:34 EST


On Tue, Oct 13, 2009 at 3:18 PM, Ingo Molnar <mingo@xxxxxxx> wrote:
>
> * Jiri Kosina <jkosina@xxxxxxx> wrote:
>
>> On Mon, 12 Oct 2009, Ingo Molnar wrote:
>>
>> > > > I came across x86/kernel/apic/nmi.c and found several typo.
>> > > > It's trivial in terms of doing nothing on changing execution logic.
>> > > I'd rather go this through x86 tree. Adding Ingo.
>> > >
>> > > > Ps. The patch is enclosed in attachment. The inline one
>> > > > is c&p of it for reading.
>> > > >
>> > > >
>> > > > Thanks,
>> > > > Luming
>> > > >
>> > > > Signed-off-by: Yu Luming <luming.yu@xxxxxxxxx>
>> > > >
>> > > > Ânmi.c | Â 18 +++++++++---------
>> > > > Â1 file changed, 9 insertions(+), 9 deletions(-)
>> > > >
>> > > > diff --git a/arch/x86/kernel/apic/nmi.c b/arch/x86/kernel/apic/nmi.c
>> > > > index b3025b4..9ff1f6d 100644
>> > > > --- a/arch/x86/kernel/apic/nmi.c
>> > > > +++ b/arch/x86/kernel/apic/nmi.c
>> > > > @@ -121,7 +121,7 @@ static void report_broken_nmi(int cpu, unsigned
>> > > > int *prev_nmi_count)
>> > > > Â Â Â Â atomic_dec(&nmi_active);
>> > > > Â}
>> > > >
>> > > > -static void __acpi_nmi_disable(void *__unused)
>> > > > +static void __apic_nmi_disable(void *__unused)
>> >
>> > that's correctly named, as a 'git grep acpi_nmi_disable' should reveal.
>>
>> I actually think that Luming Yu is right that the function is misnamed.
>> What does it have to do with ACPI?
>
> It's not misnamed - it is a facility provided by architecture code to
> the ACPI subsystem and hence named acpi_*(). See:
>
> Â5d0e600: [PATCH] x86: fix laptop bootup hang in init_acpi()

Hmm..I would put some comments around those "__acpi_xxx",
so others can know it is intended name.

>
> Other architectures could opt to implement the same quirk - but it has
> nothing to do with APIC.
>
> Yes, on x86 we use the local APIC to disable NMIs, but that has no
> effect on the naming of the facility ...
>
> Â Â Â ÂIngo
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/