Re: [PATCH 2/3] tracing: Rename set_ftrace to set_bootup_ftrace

From: Steven Rostedt
Date: Tue Oct 13 2009 - 09:25:02 EST


On Tue, 2009-10-13 at 09:38 +0200, Frederic Weisbecker wrote:
> Do this rename because set_ftrace is too much generic and not enough
> self-explainable as a name.
>
> Signed-off-by: Frederic Weisbecker <fweisbec@xxxxxxxxx>
> Cc: Steven Rostedt <rostedt@xxxxxxxxxxx>
> Cc: Li Zefan <lizf@xxxxxxxxxxxxxx>
> ---
> kernel/trace/trace.c | 4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
> index 4506826..866daf8 100644
> --- a/kernel/trace/trace.c
> +++ b/kernel/trace/trace.c
> @@ -129,7 +129,7 @@ static int tracing_set_tracer(const char *buf);
> static char bootup_tracer_buf[MAX_TRACER_SIZE] __initdata;
> static char *default_bootup_tracer;
>
> -static int __init set_ftrace(char *str)
> +static int __init set_bootup_ftrace(char *str)
> {
> strncpy(bootup_tracer_buf, str, MAX_TRACER_SIZE);
> default_bootup_tracer = bootup_tracer_buf;
> @@ -137,7 +137,7 @@ static int __init set_ftrace(char *str)
> ring_buffer_expanded = 1;
> return 1;
> }
> -__setup("ftrace=", set_ftrace);
> +__setup("ftrace=", set_bootup_ftrace);

Actually, it probably should be called, set_cmdline_ftrace. Since it
came from the command line, and that is what is matching.

-- Steve

>
> static int __init set_ftrace_dump_on_oops(char *str)
> {

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/