Re: [trivial PATCH] fix typo in nmi.c of apic

From: Jiri Kosina
Date: Mon Oct 12 2009 - 18:38:19 EST


On Mon, 12 Oct 2009, Ingo Molnar wrote:

> > > I came across x86/kernel/apic/nmi.c and found several typo.
> > > It's trivial in terms of doing nothing on changing execution logic.
> > I'd rather go this through x86 tree. Adding Ingo.
> >
> > > Ps. The patch is enclosed in attachment. The inline one
> > > is c&p of it for reading.
> > >
> > >
> > > Thanks,
> > > Luming
> > >
> > > Signed-off-by: Yu Luming <luming.yu@xxxxxxxxx>
> > >
> > > nmi.c | 18 +++++++++---------
> > > 1 file changed, 9 insertions(+), 9 deletions(-)
> > >
> > > diff --git a/arch/x86/kernel/apic/nmi.c b/arch/x86/kernel/apic/nmi.c
> > > index b3025b4..9ff1f6d 100644
> > > --- a/arch/x86/kernel/apic/nmi.c
> > > +++ b/arch/x86/kernel/apic/nmi.c
> > > @@ -121,7 +121,7 @@ static void report_broken_nmi(int cpu, unsigned
> > > int *prev_nmi_count)
> > > atomic_dec(&nmi_active);
> > > }
> > >
> > > -static void __acpi_nmi_disable(void *__unused)
> > > +static void __apic_nmi_disable(void *__unused)
>
> that's correctly named, as a 'git grep acpi_nmi_disable' should reveal.

I actually think that Luming Yu is right that the function is misnamed.
What does it have to do with ACPI?

All we do here is disable the NMI/LVT flags on the corresponding APIC. No
ACPI involved.

--
Jiri Kosina
SUSE Labs, Novell Inc.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/