Re: yenta_socket: PCMCIA-Cards are not recognised by kernel

From: Peter Stuge
Date: Fri Sep 04 2009 - 00:37:17 EST


Frans Pop wrote:
> Summary: WLAN Card (Proxim Orinoco Gold 8470-WD) is not recognized
> by either 2.6.24 or 2.6.30. After inserting it, 'lspci' does not
> list the card, but 'lspci -H1' does.
> Original message with lspci and dmesg output for .24 is at:

It would help to also see dmesg from .30 or newer, and, say, .9 or
something similarly old.

The issue is that the PCI bridge (which is what a CardBus controller
is) isn't completely configured by the kernel.

Parts of the kernel believe it is ok, which is why lspci says irq 11
for 00:02.0 and 00:02.1, but the value actually configured in the
CardBus controller hardware is 255 = unconfigured.

lspci -H1 -s 2.0 -xxx might be interesting.

The .24 dmesg shows an error initializing the PCI bus:

PCI: Probing PCI hardware
sysfs: duplicate filename 'bridge' can not be created
WARNING: at fs/sysfs/dir.c:424 sysfs_add_one()
Pid: 1, comm: swapper Not tainted 2.6.24-gentoo-r7 #1
[<c0187ceb>] sysfs_add_one+0x54/0xb8
[<c01888da>] sysfs_create_link+0xaf/0xfd
[<c02c8020>] pci_bus_add_devices+0xba/0xff
[<c037ac1d>] pcibios_scan_root+0x25/0x80
[<c011ab3d>] printk+0x1b/0x1f
[<c052822f>] pci_legacy_init+0x53/0xe1
[<c0505769>] kernel_init+0x154/0x2b6
[<c0102546>] ret_from_fork+0x6/0x20
[<c0505615>] kernel_init+0x0/0x2b6
[<c0505615>] kernel_init+0x0/0x2b6
[<c0103877>] kernel_thread_helper+0x7/0x10
pci 0000:00:02.0: Error creating sysfs bridge symlink, continuing...

This is bad, and is either the cause for the problem, or another

.24 is a bit old, so it would be interesting to see dmesg from recent
(vanilla) sources.

Christian KrÃmer wrote:
> > That means that the card should be supported by the ath5k
> > wireless driver if it was correctly initialized by the cardbus
> > drivers.

Frans is right, but the bridge isn't set up right, so cards behind it
will not work correctly either.

> Yes, but on the LiveCD, when I load the module via "modprobe ath5k",
> ifconfig
> doesn't show any interface except for lo and also dmesg don't
> display anything about a found device. In the gentoo-system I
> installed, I also tried the madwifi-ng driver package, but with the
> same result.

This is expected, until the CardBus PCI bridge starts working.

> > I don't think I can help you any further. Hopefully one of the
> > PCMCIA developers can.

To be clear, this looks like a CardBus/PCI issue. CardBus is more
like PCI and PCMCIA is more like ISA. It could maybe be an ACPI
issue, but first get to the bottom of the pci error.

> I admit I'am not very familiar with the community around the
> linux-kernel and this is my first request on the official mailing
> list.

I hope it'll be resolved, but at this point more information is
needed. Try the latest vanilla kernel. Try combinations of some
kernel parameters:


They will change how the kernel reads and thinks about interrupts.
It's important to have interrupts working right, but at this point it
seems there's a more fundamental PCI problem with the CardBus
bridges. :\

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at