Re: yenta_socket: PCMCIA-Cards are not recognised by kernel

From: Christian Krämer
Date: Thu Sep 03 2009 - 19:51:48 EST

On Thursday 03 September 2009 20:35:08 Frans Pop wrote:
> On Thursday 03 September 2009, Christian Krämer wrote:
> > On Thursday 03 September 2009 19:27:18 Frans Pop wrote:
> > > Christian: what is the PCI ID of the device? You can find out using
> > > 'lspci -H1 -nn'.
> >
> > The device class is 0200 and the PCI ID is 168c:0013.
> >
> > Here is the line lspci -H1 -nn shows for the card:
> > 01:00.0 Ethernet controller [0200]: Atheros Communications Inc.
> > AR5212/AR5213 Multiprotocol MAC/baseband processor [168c:0013] (rev 01)
> That means that the card should be supported by the ath5k wireless driver
> if it was correctly initialized by the cardbus drivers.

Yes, but on the LiveCD, when I load the module via "modprobe ath5k", ifconfig
doesn't show any interface except for lo and also dmesg don't display
anything about a found device. In the gentoo-system I installed, I also tried
the madwifi-ng driver package, but with the same result.

> I don't think I can help you any further. Hopefully one of the PCMCIA
> developers can. One last suggestion could be to enable the PCMCIA_DEBUG
> option in the kernel and activate that as documented in the Kconfig help
> for that option. Suggest you use a current kernel if you do that.
> Good luck,

I really thank you, Frans, for managing this problem, for the summary and
especially for CC'ing it to the pcmcia-mailing list. I admit I'am not very
familiar with the community around the linux-kernel and this is my first
request on the official mailing list.

Thank you very much!
Kind regards from myself
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at