Re: yenta_socket: PCMCIA-Cards are not recognised by kernel

From: Christian Krämer
Date: Wed Sep 02 2009 - 18:42:51 EST

Hi Frans,

Thank you very much indeed for your answer!

On Wednesday 02 September 2009 19:53:01 you wrote:
> Christian Krämer wrote:
> > I used a Gentoo LiveCD (Kernel 2.6.24-gentoo-r7; Platform: x86)
> That's a pretty old kernel. Any chance that you can try with a more recent
> one, such as 2.6.30? Or maybe just a more recent Gentoo CD or live CD from
> another distribution?
> Also, did you see these following messages?

I also tried to install gentoo offline (with a portage snapshot and manually
downloaded distfiles). The snapshot was form the 14th August 2009. At this
time the source packet "gentoo-sources-2.6.30-r4" was the current stable for
the x86 platform, which I used.

Maybe the output in some cases may variey, but at all I had the same problem:
dmesg only shows that a card was inserted or ejected and also lspci doesn't
listed the card (without the -H1 parameter).

After that i first tried some other *nixes, but with moderatly success.
But 'cause Linux is my favorite os, I thought, I try it with posting here on
the mailing list.

> > pcmcia: Detected deprecated PCMCIA ioctl usage from process: hwsetup.
> > pcmcia: This interface will soon be removed from the kernel; please
> > expect breakage unless you upgrade to new tools.
> > pcmcia: see
> > for
> > details.

I read this page also before, but it doesn't help. eg. pcmcia-socket-startup
doesn't help and the bridge problem with the subordinate doesn't fit, but I
already have tried the "pci=assign-busses" commandline already, unfortunately
without success.

> > warning: process `hwsetup' used the deprecated sysctl system call with
> > 1.49. warning: process `hwsetup' used the deprecated sysctl system call
> > with 1.49.
> It looks as if that Gentoo CD is still using the deprecated pcmcia-cs
> utilities instead of the new pcmciautils.

That's an idea, but in the installed gentoo system there where no hwsetup
utility (only the usual init scrips, which simply loaded the necessary
modules). I admit, that I don't know what exacly hwsetup does, but it seems
that it only look what devices are present and load the needed kernel

Maybe the following information will help to solve the Problem:

* On FreeBSD the system freezes when i insert the card and the kernel fire
frequently messages of an "interrupt storm", and that it would throttle it.
(That's the reason why I referred at the interrupt routing difference between
lspci with the "special Intel"-detection Method and without. I'm not very
familiar with lowlevel development and don't now whether this matters or

If you think it could help to install a new kernel or you need some
information or output, please tell me, it's no problem to install gentoo (or
any other distribution) with a specific kernel (and maybe some patches)

> Hope that helps,

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at