Re: xfs compat_ioctl?

From: Michael Tokarev
Date: Mon Aug 31 2009 - 09:00:05 EST

Mark Lord wrote:
Christoph Hellwig wrote:
On Mon, Aug 31, 2009 at 11:02:51AM +0400, Michael Tokarev wrote:

I tried to resize an xfs filesystem on 64bit 2.6.30 kernel
using 32bit userland, and that does not work, in dmesg I see:

ioctl32(xfs_growfs:24426): Unknown cmd fd(3) cmd(400c586e){t:'X';sz:12} arg(ffa56df4) on /mnt
ioctl32(xfs_growfs:24427): Unknown cmd fd(3) cmd(400c586e){t:'X';sz:12} arg(ff991254) on /mnt

so apparently there's no compat_ioctl layer for these ioctls.

Are there any plans to add these? :)

Are you sure you're testing 2.6.30? The copat ioctls were added in 2.6.28.

What command-line flags were you using, Michael ?

I just tried a simple "xfs_growfs -d" here, and it worked fine.
This is 2.6.31-rc7-64bit on top of a 32-bit userland.

Damn. I rebooted to 2.6.27 to test something unrelated, forgot
about it, and later tried xfs_growfs -d, which failed as per above.

And yes indeed, in 2.6.30 everything works as expected.

Please excuse me for the noise.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at