Re: [PATCH 1/4] compcache: xvmalloc memory allocator

From: Nitin Gupta
Date: Mon Aug 24 2009 - 14:41:17 EST

On 08/24/2009 11:57 PM, Pekka Enberg wrote:
On Mon, Aug 24, 2009 at 9:11 PM, Nitin Gupta<ngupta@xxxxxxxxxx> wrote:
Is the name rzmalloc() too similar to kzalloc() which stands for
zeroing allocator, though? I think I suggested
ramzswap_alloc()/ramzswap_free() in the past to avoid confusion. I'd
rather go with that if we can't come up with a nice generic name that
stands for alloc_part_of_page_including_highmem().

rzs_malloc()/rzs_free() ?

I am not sure what we gain from the shorter and more cryptic "rzs"
prefix compared to "ramzswap" but yeah, it's less likely to be
confused with kzalloc() so I'm okay with that.

Perhaps, I'm just too bad with naming :)

xvmalloc -> ramzswap_alloc() (compiled with ramzswap instead of as a separate module).

BTW, [rzs]control is the name of userspace utility to send ioctl()s to ramzswap.
Somehow, I am happy with rzscontrol name atleast.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at